Konfigurasi RIP Protocol pada Cisco Router

Definisi Protocol RIP

Routing Information Protocol adalah sebuah dinamic routing protocol yang menggunakan Hop Count sebagai Metric Routingnya untuk mencari route yang terbaik (The Best Path) antara sumber dengan tujuan network. RIP merupakan tipe dari Interior Gateway Protocol (IGP) dan menggunakan Distance Vector sebagai metode routing dengan nilai AD 120. jumlah Metric routing pada RIP hanya Max 15 Hop, dimana jika ada Hop ke 16 maka dianggap sebagai jaringan yang tidak dapat dijangkau. Algoritma Routing Bellman-Ford. RIP menggunakan Port 520 UDP.

RIP tidak menggunakan Wildcard Mask pada Network Statementnya, juga AS (Autonomous System) atau ASN (Autonomous System Number) pada proses routingnya.

Feature of RIP

  1. Support Authentication.
  2. Penggunaan CPU/Memory yang kecil.
  3.  Pencegahan Loop menggunakan Hold Down Timer, Split Horizon, Poison Reverse.
  4. Update Network secara berkala.
  5. Pembaharuan Information Routing mengunakan Broadcast.
  6. Router selalu percaya pada Information Routing yang dikirimkan oleh tetangga. (bisa menjadi keunggulan maupun kekurangan sih ini).

adapun perbedaan RIP Version 1 dan Version 2 ;

No RIP Version 1 RIP Version 2 RIP NG
1 Mengirim Update sebagai Broadcast Mengirim update sebgai Multicast Mengirim update sebgai Multicast
2 IP Broadcast menggunakan 255.255.255.255 IP Multicast menggunakan 224.0.0.9 IP Multicast mengunakan FF02::9 (RIPng hanya bisa running pada IPv6 networks)
3 Tidak mendukung otentikasi dari Update Messages Support Otentikasi Update Messages
4 Classful routing protocol Classless Routing Protocol, juga mendukung Classfull Routing Protocol. Classless Update dikirim

 

Configuring RIP Routing

contoh topologi :

Diagram-rip

Configure IP Addreses

Pertama lakukan konfigurasi IP Adress pada masing – masing Router, berikut :

  • Router R0
R0(config)#interface gigabitEthernet 0/0
R0(config-if)#ip address 10.10.10.2 255.255.255.252
R0(config-if)#description Link-To-R1
R0(config-if)#no shutdown

R0(config)#interface gigabitEthernet 0/1
R0(config-if)#ip address 5.5.5.1 255.255.255.0
R0(config-if)#description Link-To-Local
R0(config-if)#no shutdown

R0(config)#interface loopback 0
R0(config-if)#ip address 1.1.1.1 255.255.255.255
R0(config-if)#no shutdown
  • Router R1
R1(config)#interface gigabitEthernet 0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.252
R1(config-if)#description Link-To-R0
R1(config-if)#no shutdown

R1(config)#interface gigabitEthernet 0/1
R1(config-if)#ip address 192.168.0.1 255.255.255.252
R1(config-if)#description Link-To-R2
R1(config-if)#no shutdown

R1(config)#interface gigabitEthernet 0/2
R1(config-if)#ip address 6.6.6.1 255.255.255.0
R1(config-if)#description Link-To-Local
R1(config-if)#no shutdown
R1(config)#interface loopback 0
R1(config-if)#ip address 2.2.2.2 255.255.255.252
R1(config-if)#no shutdown
  • Router R2
R2(config)#interface gigabitEthernet 0/0
R2(config-if)#ip address 192.168.0.2 255.255.255.252
R2(config-if)#description Link-To-R2
R2(config-if)#no shutdown

R2(config)#interface gigabitEthernet 0/1
R2(config-if)#ip address 7.7.7.1 255.255.255.0
R2(config-if)#description Link-To-Local
R2(config-if)#no shutdown

R2(config)#interface loopback 0
R2(config-if)#ip address 3.3.3.3 255.255.255.255
R2(config-if)#no shutdown

 

Setelah anda lakukan setting IP Address, pastikan anda save konfigurasi dengan syntax “Write Memory”.

Configure RIP Routing (Version 1)

Oke, setelah melakukan konfigurasi IP Address pada masing-masing router, kemudian kita lakukan konfigurasi Routing RIP, dalam contoh pertama, saya lakukan RIP Version 1, seperti yang sudah saya jelaskan sebelumnya, RIP Version 1 masih menggunakan Classfull Routing. Berikut konfigurasi RIP Versi 1 ;

  • Router R0
R0(config)#router rip
R0(config-router)#network 10.10.10.2 
R0(config-router)#network 5.5.5.1
R0(config-router)#network 1.1.1.1
  • Router R1
R1(config)#router rip
R1(config-router)#network 10.10.10.1
R1(config-router)#network 192.168.0.1
R1(config-router)#network 6.6.6.1
R1(config-router)#network 2.2.2.2
  • Router R2
R2(config)#router rip
R2(config-router)#network 192.168.0.2
R2(config-router)#network 3.3.3.3
R2(config-router)#network 7.7.7.1

 

Setelah konfigurasi routing rip versi 1 diatas, jangan lupa save konfigurasi, biasakan setelah anda melakukan konfigurasi, langsung lakukan save konfigurasi. Setelah itu silahkan check routing RIP yang baru dikonfigurasi sudah berfungsi belum ? kalian bisa chek menggunakan syntax “Show IP Route”, “Show ip rip database”, “Show ip protocols” pada masing-masing router.

Setelah anda cek menggunakan Show IP route pada masing-masing router, kalian bisa perhatikan pada Code R yang artinya Protocol RIP, IP Address yang ditampilkan masih menggunakan IP Classfull. Berikut hasil pengecekkannya :

  • R0

Routing-RIP-R0-Show-IP-Route-v1

 

Configure RIP Routing (Version 2)

Oke, Konfigurasi RIP version 1 sudah selesai, hasilnya koneksi antar router sukses terhubung. Kemudian kita coba menggunakan RIP versi 2 dengan hanya merubah pada konfigurasi sebagai berikut :

  • R0
R0(config)#router rip
R0(config-router)#version 2
R0(config-router)#exit

Oke, sebelum router R1 dan R2 kita ganti RIP Versionnya, ada yang ingin saya perlihatkan, bahwa ketika dilakukan “Ping” ke Host PC yang berada dibawah router R1 dan R2 yang masih menggunakan RIP Version 1, maka yang terjadi adalah RTO.

Ping ke Router R1

Ping ke Router R2

apa yang terjadi ? kok ga bisa ping reply, ternyata router R0 yang sudah kita ubah menjadi RIP Version 2 tadi menolak menerima paket update routing dari R1 dan R2 yang masih menggunakan RIP Version 1. berikut debugnya :

  • R0

sudah jelas kah ? diatas terlihat, R0 meng-ignore paket dari R1 yang dianggap illegal version karena versionnya berbeda. oke selanjutnya kita coba ubah router R1 dan R2 menjadi RIP version 2, sebagai berikut ;

  • R1
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#exit
  • R2
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#exit

oke jika sudah, silahkan lakukan Ping Connection ke masing-masing router, hasilnya anda sudah bisa kembali terkonneksi antar router. Berikut contoh dari update paket routing RIP menggunakan RIP Version 2, dengan melakukan perintah debug ip rip events.

  • R1

  • R2

 

Passive Interface

Passive Interface adalah fitur pada Router Cisco yang dapat digunakan pada Interface router agar tidak akan mengirim routing update kepada interface yang terdaftar sebagai passive interface dan hanya menerima (pasif) routing update dari router lain. Cara kerjanya adalah dengan menjadikan suatu interface menjadi silent host atau dengan kata lain membiarkan interface tersebut tetap menerima broadcast paket routing dari interface yang aktif, sementara interface yang passive tidak memberikan broadcast ke neighbor alias hanya menerima paket saja. Umumnya Passive Interface ini diterapkan pada Interface yang tidak berhubungan langsung dengan link router lain.

Bingung yak ? sama !!!

oke biar ga bingung, gw jelasin dalam bentuk topologi yak.

Perhatikan pada topologi jaringan Lab diawal artikel ini, ada router R0, R1 dan R2. Pada masing-masing router tersebut terdapat Interface yang terhubung dengan router lain sebagai jalur untuk berkomunikasi, seperti R0 memiliki Interface GE0/0, R1 memiliki Interface GE 0/0 dan GE0/1, kemudian R2 memiliki interface GE0/0. pada interface tersebutlah paket update routing di-distribusikan ke masing-masing Router.

Lalu bagaimana dengan interface yang mengarah ke LAN Host PC, seperti R0 memiliki Interface GE0/1 dan Interface Loopback 0 yang mengarah ke jaringan LAN, begitu juga pada R1 memiliki Interface GE0/2 dan Interface Loopback 0, R2 memiliki Interface GE0/1 dan Interface Loopback 0. pada interface inilah yang tidak perlu dikirimi routing update karena interface tersebujt lawannya tidak ada yang aktif routing protocol RIP-nya.

Perhatikan pada lingkaran merah, terdapat Interface Loopback 0 dan Inteface GigabitEthernet 0/1 yang mengirim Routing Update protocol Rip ke lawan/Neighboornya, padahal lawannya tersebut merupakan sebuah Host LAN. kita dapat mematikan routing update yang ke arah Interface Loopback dan Interface GE0/1 dengan perintah “passive-interface”

  • R0
R0(config)#router rip
R0(config-router)#passive-interface gigabitEthernet 0/1
R0(config-router)#passive-interface loopback 0

kemudian coba cek kembali rip event, berikut sebagai contoh :

perhatikan pada gambar diatas, bahwa sudah tidak ada lagi pengiriman routing update ke interface loopback dan GE0/1.

Default Passive Interface

Jika pada cara sebelumnya kita melakukan konfigurasi passive interface akan sangat merepotkan jika jumlah interface mengarah ke jaringan LAN atau Interface yang ingin kita jadikan passive interface banyak dalam 1 router. itu baru 1 router, bayangkan jika anda handle 2, 3, 4 router atau lebih, akan sangat membuang waktu bukan ?

Maka ada cara yang lebih sederhana, yakni kita matikan terlebih dahulu semua interface pada router, kemudian aktifkan yang dibutuhkan saja. berikut caranya ;

  • R1
R1(config)#router rip
R1(config-router)#passive-interface default
R1(config-router)#no passive-interface GigabitEthernet 0/0
R1(config-router)#no passive-interface GigabitEthernet 0/1

Berikut hasilnya jika dilihat dengan perintah “debug ip rip event” ;

Maka terlihat dengan menggunakan cara seperti ini, pengiriman routing update hanya ke interface tertentu yang diperlukan saja, jadi traffic jaringan anda lebih hemat bandwidth dan hemat pada proses pengiriman routing update pada router. cmiiw.

Using Default-Information-Originate as RIP Default Route

Default Information Originate berfungsi untuk membuat default route didalam protokol RIP sebuah router, sehingga apabila mengaktifkan Default Information Originate ini maka sebuah router mendeklarasikan dirinya sebagai default route bagi router lain. maksudnya begini Jika pada Routing Table pada suatu router tidak ada network tujuan maka router akan mengambil di routing table yang ada tanda *R.

sebagai simulasinya, scenarionya seperti ini :

  1. Saya menjadikan Router R1 sebagai Default Information Originate (Router yang mendeklarasikan diri sebagai Default Route). Sehingga R0 dan R2 akan menanyakan kepada R1 jika terdapat Destination Network yang tidak ada pada routing table R0 dan R2.
  2. Untuk Network LAN ( 6.6.6.0/24 dan 2.2.2.2/32 ) pada Router R1 saya tidak daftarkan pada routing RIP. sehingga dengan begini, router R0 dan Router R2 tidak mengenali jaringan tersebut.

Pertama hapus terlebih dahulu segment network 6.6.6.0/24 dan 2.2.2.2/32 pada Router R1.

  • R1
R1(config)#router rip 
R1(config-router)#no network 6.6.6.0
R1(config-router)#no network 2.2.2.2
R1(config-router)#default-information originate

sampai disini, router R1 sudah menjadi Default Route, berikutnya silahkan cek routing table pada Router R0 dan R2, akan terdapat simbol *R pada Routing Rable, yang artinya jika network tujuan tidak terdapat pada routing table, akan diforward ke *R.

  • R0

  • R2

kemudian, coba test Ping.

  • R0

  • R1

 

Using Redistribute Static as RIP Default Route

Sama seperti pada Default Information Originate, kali ini menggunakan Redistribute Static. jangan lupa hapus dulu konfigurasi default-information originate sebelumnya. Redistribute Stati bisa menggunakan Next-Hop IP, Exit Interface, juga Interface Null, pada kesempatan kali ini, saya menggunakan Interface Null. menggunakan interface Null 0 yang berarti routingnya akan dilempar ke dirinya sendiri lalu akan di redistribute ke member routing RIP.

  • R1
R1(config)#ip route 0.0.0.0 0.0.0.0 null0
Default route without gateway, if not a point-to-point interface, may impact performance

R1(config)#router rip 
R1(config-router)#no default-information originate
R1(config-router)#redistribute static

RIP Timer

pada Protocol RIP, tidak ada namanya Hello Packet melainkan Routing Update Packet. Nah Routing Update Packet ini dikirimkan dengan interval waktu tertentu, secara default setiap 30s, Invalid 180s, Holddown 180s, Flushed 240s.

  • Invalid Timer : Jika dalam 180 detik ga diterima update dari tetangga, maka tetangga itu akan di tandai / di “mark” Invalid. Dan dikasih metric atau hop 16
  • Flush Timer : jika dalam 60 detik setelah Invalid Timer, route yang mati di buang dari routing table. sampai tahap ini total 240 detik (180s + 60s).
  • Holddown : Jika dalam 180 detik setelah di mark unreachable/invalid. Maka routing update yang mengarah ke tetangga tersebut akan di tolak.

Untuk merubah nilai timer maka semua router yang menjadi member RIP diwajibkan dirubah juga timer-nya. Berikut cara merubah update 10s, Invalid & Holddown 60, Flush 80 :

timers basic <interval-updates>  <invalid>  <holddown>  <flush>

Sebagai contoh pada R1, mari lihat default RIP Timernya ;

Show_IP _Protocols - RIP_Timers

dapat dilihat, R1 memiliki Rip Timer Default 30 detik untuk mengirim Updates, Invalid 180, Holddown 180, dan Flush 240.

  • R1
R1(config)#router rip
R1(config-router)#timers basic 40 120 100 200
R1(config-router)#exit

kemudian, lakukan pengecekkan kembali, dengan mengetikan syntax “Show IP Protocols”;

how IP Protocols - RIP Timers - sesudah

 

Leave a Comment

Your email address will not be published. Required fields are marked *