Cara Konfigurasi OSPF Lanjutan Pada Cisco Router

Setelah kita pelajari konfigurasi dasar dari OSPF pada postingan saya sebelumnya, postingan kali ini merupakan lanjutan dari postingan sebelumnya, langsung saja. Untuk Topologi masih sama dengan sebelumnya sebagai berikut :

cara-konfigurasi-dasar-ospf

DR / DBR Election Process

Pada Routing OSPF, dikenal nama DR ( Designated Router ) dan ada juga BDR ( Backup Designated Router ), DR BDR ini berfungsi sebagai router yang mewakili informasi update kepada router-router lainnya. DR BDR ini sangat berguna jika topologi OSPF anda merupakan type Broadcast Multiaccess Network.

Poses pemilihan router yang berfungsi sebagai DR adalah router yang memiliki nilai priority tertinggi, nilai default priority pada router adalah 1, jika nilai priority antar masing-masing router itu sama, maka proses pemilihannya akan ditentukan dengan Router ID ( RID ) yang tertinggi, entah itu berdasarkan force router-id, IP interface loopback tertinggi maupun IP Inteface Phisical Tertinggi, silahkan baca pada postingan OSPF sebelumnya.

Kemudian yang akan bertindak sebagai BDR yaitu kebalikkan dari proses pemilihan DR. :D.

Selain itu jika nilai Priority di setting 0, maka router tersebut akan menjadi DROther, yang mana tidak ikut dalam pemilihan DR/BDR.

 

cara-konfigurasi-ospf-lanjutan

Proses Election hanya mengambil beberapa detik saja, jika semua router yang berada pada multiaccess network tidak selesai booting, ini memungkinkan router yang memiliki Router ID yang rendah akan menjadi DR. Ini bisa saja terjadi pada router yang Router ID yang lebih lama untuk booting. Bisa juga Router ID yang memiliki ID paling tinggi itu lama dalam proses Bootingnya, sehinga tidak menjadi DR.

Sebagai contoh, pada gambar diatas, Router C bertindak sebagai DR karena memiliki Router ID yang paling tinggi, jika Router C lambat booting, maka yang menjadi DR adalah Router B, dan jika Router C selesai melakukan booting, maka Router B tetap menjadi DR, dan Router A menjadi BDR.

Oke, Langsung saja, kita lihat pada masing-masing router. Dengan cara ketikkan syntax show interface gigabitEthernet0/0.

Router Jakarta

Router Semarang

Dapat dilihat tulisan yang saya cetak tabal, pada router jakarta menjadi BDR dengan nilai Priority 1 ( Default ). Kemudian pada Router Semarang menjadi DR dengan nilai Priority 1 ( Default ). Karena nilai priority pada router yang berhadapan itu masih default belum diubah-ubah, maka proses pemilihan DR BDR menggunakan Router ID. Anda dapat bandingkan Router ID antara Router Jakarta dengan Semarang, Jakarta RID 5.5.5.5 dan Semarang RID 6.6.6.6,  maka Router Semarang yang akan menjadi DR.

Sekarang kita Ubah Priority, agar dapat menentukan router mana yang menjadi DR dan router mana yang menjadi BDR.

Jakarta(config)#interface gigabitEthernet 0/0
Jakarta(config-if)#ip ospf priority 3
Jakarta(config-if)#no shutdown

Kemudian kita check lagi ya, apakah DR BDR telah berubah atau belum.

Router Jakarta

Router Semarang

Dapat anda lihat setelah diubah nilai priority-nya, maka langsung berubah DR BDR pada masing-masing router. Selanjutnya kita coba ubah DR BDR antara router Semarang dengan Surabaya.

Router Semarang

Router Surabaya

dapat dilihat, Antara Router Semarang dengan Router Surabaya,  yang bertindak sebagai BDR adalah Router Semarang, yang menjadi Router DR adalah Router Surabaya. Kemudian kita ubah nilai priority-nya :

Semarang(config)#interface gigabitEthernet 0/1
Semarang(config-if)#ip ospf priority 2
Semarang(config-if)#no shutdown

Selanjutnya kita cek kembali, apakah DR BDR berubah.

Router Semarang

Router Surabaya

Yes, berhasil ya, DR BDR bisa kita tentukan dengan mengubah nilai priority pada interface router.

Berikut Kesimpulan dari DR BDR dari Packetlife.net :

  • The DR serves as a common point for all adjacencies on a multiaccess segment
  • The BDR also maintains adjacencies with all routers in case the DR fails
  • Election does not occur on point-topoint or multipoint links
  • Default priority (0-255) is 1; highest priority wins; 0 cannot be elected
  • DR preemption will not occur unless the current DR is reset

Tipe Router OSPF

OSPF terdapat 4 type :

  1. O = Rute OSPF biasa atau intra area.
  2. O IA = Rute OSPF yang didapat dari OSPF area lain.
  3. O E1 = Rute OSPF yang didapat dari routing protocol lain tipe 1.
  4. O E2 = Rute OSPF yang didapat dari routing protocol lain tipe 2.

ABR = Router yang menghubungkan beda area.

ASBR = Router yang menghubungkan OSPF dengan Routing protocol lain

 

Metric Calculation

Di OSPF menggunakan Cost sebagai Metric, dimana untuk menentukan rute/path terbaik dengan mengakumulasi nilai cost terendah, kemudian akan ditampilkan ke dalam tabel routing, pada cisco menggunakan parameter Bandwidth  interface untuk menentukan Cost. Berikut tabel Costnya :

OSPF

Adapun kita dapat menghitung bandwidth di OSPF dengan Rumus :

Cost = ( 108 / Bandwidth Interface Out (bit) )

Mari kita lihat nilai metric dari PC-Jakarta ke PC-Surabaya, yang melewati Router Jakarta – Semarang – Surabaya.

 

 

Jika kita rangkum dan jumlahkan, maka :

Router Bandwidth
Jakarta 1000000000
Semarang 1000000000
Surabaya 1000000000

 

Cost = 1 + 1 + 1 = 3.

kemudian kita check, apakah benar hitungan diatas :

*** Belum Selesai ***

Default Route

Untuk membuat Default Route pada OSPF hanya bisa menggunakan perintah “default-information originate”, Pada OSPF tidak mendukung redistribute Static. Default Route disini dimaksudkan jika routing table tidak ada network tujuan maka router akan mengambil di routing table yang ada tanda/simbol O* pada tabel routing. dengan kata lain, Router yang di konfigurasi default route, maka router tersebut mendeklarasikan dirinya kepada router lain, bahwa jika ada network yang tidak ada pada routing tabel maka akan dilarikan ke router yang dikonfigurasi default route.

Bingung ya ? kita langsung konfig saja ya.

saya scenariokan bahwa Router Jakarta sebagai Default route bagi router Semarang dan router Surabaya. mari dimulai.

Pertama, Check Routing Table masing-masing router.

Router Jakarta

Router Semarang

Router Surabaya

Kemudian, lakukan konfigurasi Default Route pada router Jakarta, sesuai scenario diatas.

Jakarta(config)#ip route 0.0.0.0 0.0.0.0 null 0
%Default route without gateway, if not a point-to-point interface, may impact performance
Jakarta(config)#router ospf 1
Jakarta(config-router)#default-information originate

saya coba jelaskan sedikit.

Syntax “ip route 0.0.0.0 0.0.0.0 null 0” melakukan default route ke 0.0.0.0  melalui interface null.

Syntax “router ospf 1” masuk ke routing ospf process.

Syntax “default-information originate” melakukan generate default external route didalam routing OSPF.

Oke, sekarang kita check kembali Routing Table pada masing-masing router.

Router Semarang

Router Surabaya

See !!! lihat ada perbedaan kah sebelum dikonfig Default Route & Default-Information Originate maupun sesudah ??? Yess That Right.. pada routing tabel terdapat Simbol S* pada router Jakarta, dan terdapat simbol O*E2 pada Router Semarang dan Surabaya. yang artinya Routing OSPF dapat dari External Routing yakni Static Routing. sekarang kita simulasikan dengan cara tambahkan Network baru pada Router Jakarta, namun tanpa di advertise ke Routing OSPF.

Jakarta(config)#interface Loopback4
Jakarta(config-if)#ip address 33.33.33.33 255.255.255.255
Jakarta(config)#interface Loopback5
Jakarta(config-if)#ip address 44.44.44.44 255.255.255.255

 

Jika sudah ditambahkan, coba lakukan perintah Ping dari Router Semarang / Surabaya atau PC-Semarang / PC-Surabaya.

konfigurasi-ospf-lanjutan-defaultroute konfigurasi-ospf-lanjutan-defaultroute

See.!! Router Semarang & Router Surabaya dapat terkoneksi ke network 33.33.33.33 & 44.44.44.44 yang padahal tidak di advertise di ospf, namun dengan bantuan Default Route, jadi bisa.

OSPF Authentication

ada 3 tipe otentikasi OSPF :

  1. Tipe 0 yang berarti tidak ada Authentication.
  2. Tipe 1 yang berarti Authentication berupa clear text.
  3. Tipe 2 yang berarti Authentication mengunakan Message-Digest.

Jika berhasil, akan muncul notifikasi sebagai berikut.

01:14:11: %OSPF-5-ADJCHG: Process 2, Nbr 5.5.5.5 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

Dan jika tidak terhubung, akan muncul notifikasi sebagai berikut.

01:03:41: %OSPF-5-ADJCHG: Process 1, Nbr 6.6.6.6 on GigabitEthernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired

01:03:41: %OSPF-5-ADJCHG: Process 1, Nbr 6.6.6.6 on GigabitEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached

Untuk lebih jelasnya silahkan kalian debug.

OSPF Authentication Using Clear Text

Pada OSPF, terdapat 2 mode Authentication yakni, via Interface maupun via OSPF Area. Jika kita menggunakan via interface berarti interface yang saling berhadapan yang harus menggunakan OSPF Authentication.

Jika anda memilih authentication menggunakan via OSPF Area, maka semua router yang tergabung dalam 1 area tersebut wajib menggunakan OSPF Area Authentication.

Keduanya ( via Interface maupun via OSPF Area ) password harus sama, sehingga match.

Nah, kalo misalnya Passwordnya sama pada masing-masing router, tapi beda tipe authenticationnya, bisa terbentuk ga ? tentu tidak bisa terbentuk koneksinya, begini penjelasannya :

Jika Router Semarang menggunakan Authentication type 2, dan Router Surabaya menggunakan Authentication type 1, maka tidak bisa terbentuk koneksinya, akan muncul notifikasi error saat lakukan debug.

Semarang#debug ip ospf events

OSPF events debugging is on

00:09:20: OSPF: Rcv pkt from 192.168.0.2, GigabitEthernet0/1 : Mismatch Authentication type. Input packet specified type 0, we use type 2

Authentication Clear Text Using Interface

Oke kita coba konfigurasi Authentication OSPF menggunakan Interface. Berikut konfigurasinya

Jakarta(config)#interface gigabitEthernet 0/0
Jakarta(config-if)#ip ospf authentication
Jakarta(config-if)#ip ospf authentication-key admin123
Jakarta(config-if)#no shutdown
Semarang(config)#interface gigabitEthernet 0/0
Semarang(config-if)#ip ospf authentication
Semarang(config-if)#ip ospf authentication-key admin123
Semarang(config-if)#no shutdown

Penjelasan :

Syntax “ip ospf authentication” untuk mengaktifkan mode authentification.

Syntax “ip ospf authentication-key admin123” maksudnya memberikan password “admin123”.

Authentication Clear Text Using OSPF Area

Untuk dapat configurasi Authentication Clear Text pada OSPF Area, tidak jauh berbeda, hanya mengaktifkan Authenticationnya pada OSPF Area, kemudian passwordnya tetap dikonfigurasi pada interface.
Sebelum kita coba konfigurasi, Hapus terlebih dahulu konfugurasi pada Sub-bab sebelumnya yaitu Authentication Clear Tex Using Interface. caranya :

Jakarta(config)#interface gigabitEthernet 0/0 
Jakarta(config-if)#no ip ospf authentication 
Jakarta(config-if)#no ip ospf authentication-key admin123 
Jakarta(config-if)#no shutdown
 
Semarang(config)#interface gigabitEthernet 0/0 
Semarang(config-if)#no ip ospf authentication 
Semarang(config-if)#no ip ospf authentication-key admin123 
Semarang(config-if)#no shutdown 

 

Setelah konfigurasi sebelumnya dihapus, mari mulai konfigurasi Authentication Clear Text Using OSPF Area. caranya :

Jakarta(config)#Router ospf 1
Jakarta(config-if)#area 0 authentication
Jakarta(config-if)#exit

Jakarta(config)#Interface GigabitEthernet 0/0
Jakarta(config-if)#ip ospf authentication-key c!$c0
Semarang(config)#router ospf 2
Semarang(config-router)#area 0 authentication
Semarang(config-if)#exit

Semarang(config)#interface gigabitEthernet 0/0
Semarang(config-if)#ip ospf authentication-key c!$c0
Semarang(config-if)#no shutdown

 

biar gw jelasin dulu sedikit konfigurasi diatas.

syntax ” area 0 authentication” untuk mengaktifkan autentication clear text mode dalam router ospf 1.

kemudian syntax “ip ospf authentication-key c!$c0” maksudnya memberikan password “c!$c0” , sama seperti memberikan password authentication ospf via interface mode.

kemudian, tunggu sampai muncul notification adjacent, seperti dibawah. kemudian silahkan cek koneksinya.

Jakarta(config)#
00:10:10: %OSPF-5-ADJCHG: Process 1, Nbr 6.6.6.6 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

 

Semarang(config)#
00:10:10: %OSPF-5-ADJCHG: Process 2, Nbr 5.5.5.5 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

OSPF Authentication Using Message-Digest

Nah, seperti yang sudah gua jelasin pada Sub OSPF Authentication Using Clear Text diatas, Pada OSPF, terdapat 2 mode Authentication yakni, via Interface maupun via OSPF Area. Jika kita menggunakan via interface berarti interface yang saling berhadapan yang harus menggunakan OSPF Authentication.

Nah, pada Authentication menggunakan Message-Digest ini selain password harus sama, Key ID pun juga harus sama, Key-ID yang disediakan dari 1 – 255. jika berbeda maka tidak akan terbentuk, berikut notifikasi jika Key ID antara Router Surabaya dengan Semarang berbeda saat dikonfig, lihat di debug.

Surabaya#debug ip ospf events

OSPF events debugging is on

Surabaya#

00:14:20: OSPF: Send with youngest Key 2

00:14:21: OSPF: Rcv pkt from 192.168.0.1, GigabitEthernet0/0 : Mismatch Authentication Key – No message digest key 1 on interface

Notifikasi diatas, terjadi ketika saya konfigurasi Router Semarang menggunakan Key-ID 1, dan Router Surabaya menggunakan Key-ID 2. Maka ingat, Key-ID haruslah sama.

Authentication Message-Digest Using Interface

Sekarang kita coba konfigurasi Authentication OSPF Message-Digest menggunakan Interface. Berikut konfigurasinya :

Semarang(config)#interface gigabitEthernet 0/1
Semarang(config-if)#ip ospf authentication message-digest
Semarang(config-if)#ip ospf message-digest-key 1 md5 admin123
Semarang(config-if)#no shutdown
Surabaya(config)#interface gigabitEthernet 0/0
Surabaya(config-if)#ip ospf authentication message-digest
Surabaya(config-if)#ip ospf message-digest-key 1 md5 admin123
Surabaya(config-if)#no shutdown

Authentication Message-Digest Using OSPF Area

oke, sekarang kita coba Authentication message-digest menggunakan Ospf Area. area yang ingin kita buat authentication adalah area 2. sebelumnya kita hapus dulu konfigurasi Authentication Message-digest menggunakan Interface Mode yang telah kita buat sebelumnya. berikut cara hapusnya :

Semarang(config)#interface gigabitEthernet 0/1
Semarang(config-if)#no ip ospf message-digest-key 1 md5 admin123
Semarang(config-if)#no ip ospf authentication message-digest
Semarang(config-if)#no shutdown 
Surabaya(config)#interface gigabitEthernet 0/0
Surabaya(config-if)#no ip ospf authentication message-digest
Surabaya(config-if)#no ip ospf message-digest-key 1 md5 admin123
Surabaya(config-if)#no shutdown

Selanjutnya, aktifkan terlebih dahulu authentication message-digest pada area 2. Berikut konfigurasinya ;

Router Semarang

Semarang(config)#router ospf 2
Semarang(config-router)#area 2 authentication message-digest
Semarang(config-router)#exit

Router Surabaya

 
Surabaya(config)#router ospf 3 
Surabaya(config-router)#area 2 authentication message-digest 
Surabaya(config-router)#exit

kemudian, selanjutnya masuk ke interface out yang mengarah/tergabung dengan area 2 OSPF. Kemudian berikan password untuk authentication message-digest, dalam hal ini password yang saya masukkan adalah “c!sc0″ , Berikut konfigurasinya ;

Router Semarang

Semarang(config)#interface gigabitEthernet 0/1
Semarang(config-if)#ip ospf message-digest-key 1 md5 C!sc0
Semarang(config-if)#no shutdown

Router Surabaya

Surabaya(config)#interface gigabitEthernet 0/0
Surabaya(config-if)#ip ospf message-digest-key 1 md5 C!sc0
Surabaya(config-if)#no shutdown

jika sudah akan muncul notifikasi adjacent. seoerti berikut ;

Semarang(config)#
00:28:11: %OSPF-5-ADJCHG: Process 2, Nbr 7.7.7.7 on GigabitEthernet0/1 from LOADING to FULL, Loading Done

 

Surabaya(config)#
00:28:11: %OSPF-5-ADJCHG: Process 3, Nbr 6.6.6.6 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

 

Oke, segittu aja dulu, jika ada pertanyaan, silhkan isi komentar dibawah,

Terima Kasih.

Leave a Comment

Your email address will not be published. Required fields are marked *