CARA KONFIGURASI DYNAMIC ROUTING : EIGRP PADA ROUTER CISCO

Pada postingan ini, saya ingin menjelaskan perihal Cara Konfigurasi Dynamic Route : EIGRP pada Router Cisco. Baik, seperti kita ketahui, Routing Protocol memiliki 2 tipe ; 1. Static Routing, 2. Dynamic Routing. Static Routing kalian bisa baca pada postingan saya sebelumnya tentang Cara Konfigurasi Static Route pada Router Cisco.

kemudian untuk Dynamic Routing adalah Routing yang Path/jalurnya ditentukan secara automatis oleh protocol routing itu sendiri dengan berdasarkan algoritma yang dipakai.

Definisi EIGRP

EIGRP merupakan singkatan dari Enhanced Interior Gateway Routing Protocol yakni sebuah protocol yang termasuk dalam kategori Interior Gateway Protocol yang cocok untuk berbagai topologi dan media. dalam jaringan yang dirancang dengan baik, EIGRP memiliki skala yang baik dan menyediakan waktu konvergensi yang sangat cepat. Nah konvergensi yang sangat cepat ini dikarenakan EIGRP menggunakan Algoritma DUAL yang memungkinkan information routing untuk konvergensi tercepat dari pada protocol routing lain saat ini. Protocol EIGRP ini dikembangkan oleh Cisco, dan saat ini protocol tersebut hanya bisa digunakan pada Product Cisco saja.

Fitur EIGRP

  • Increased network width = EIGRP memiliki skala jaringan yang luas & lebar. yang mana Default Hop Limit pada EIGRP yakni 100 Hop.
  • Fast convergence = EIGRP memiliki waktu convergensi yang sangat cepat, sehingga dapat mengurangi waktu downtime jika terjadi link failure.
  • Partial updates = tidak seperti protocol RIP yang selalu mengirimkan keseluruhan tabel routing dalam pesan Update, EIGRP hanya mengirimkan Partial Update atau Trigger Update ketika status dari sebuah source network maupun network destination ada perubahan. fitur ini meminimalkan bandwidth yang diperlukan untuk paket EIGRP.
  • Neighbor discovery mechanism = EIGRP menggunakan mekanisme Hello Paket yang digunakan untuk mempelajari tentang perangkat sebelahnya/perangkat tetangganya.
  • Scaling = Skala EIGRP digunakan untuk jaringan berskala besar.
  • Advanced Distance Vector = EIGRP termasuk protokol routing yang menggunakan metode Distance Vector tingkat lanjut (Hybrid).
  • Supported VLSM = EIGRP supported VLSM Method and Subnet that Discontiguous (tidak bersebelahan/berurutan).
  • Load Balancing over Cost Equal and Unequal Path = EIGRP dapat menggunakan 2 Link atau lebih ke suatu network destination dengan koneksi bandwidth (Cost Metric) yang berbeda, dan melakukan Load Sharing pada link-link tersebut dengan beban yang sesuai yang dimiliki oleh masing-masing Link, dengan begini pemakaian bandwidth pada setiap link menjadi lebih efektif, karena link dengan bandwidth yang lebih kecil tetap digunakan dan dengan beban yang sesuai dengan link tersebut.
  • Metric Base Path = EIGRP menggunakan pemilihan jalur terbaik berdasarkan Metric.

Administrative Distance Table

Dalam Terminologi Routing, dikenal istilah Tabel Administrative Distance Number, dimana dalam tabel tersebut berisikan number yang digunakan secara Default oleh perangkat router anda dalam menentukan Protocol Routing mana yang akan digunakan. Perangkat Router akan mengunakan Protocol Routing yang memiliki value/nilai yang terkecil dalam router anda, berikut tabel Administrative Distance.

Tabel Default Value of Administrative Distance

Cara-Setting-Static-Route-pada-Router-Cisco

Sebagai contoh, jika anda melakukan konfigurasi Static Routing dan RIP 2 Dynamic Routing pada router anda. maka router anda akan menggunakan Protocol Static Routing sebagai Main Route untuk mengirimkan paket data. karena Static Route memiliki nilai 1 dibandingkan Protocol RIP 2 yang memiliki nilai 120. kira-kira seperti itu gambarannya.

Cara Konfigurasi EIGRP

Oke, berikut Cara Konfigurasi Dynamic Routing : EIGRP pada Router Cisco. sebagai contoh, saya coba buat topologi sederhana dibawah ini :

Car-Konfigurasi-EIGRP

Pertama, setting terlebih dahulu ip address pada masing masing interface router. Dan pastikan koneksi antar router telah established.

Konfigurasi IP Address Router Jakarta

jakarta(config)#interface Loopback0
jakarta(config-if)#ip address 30.30.30.1 255.255.255.252

jakarta(config)#interface Serial0/0/0
jakarta(config-if)#ip address 10.10.10.2 255.255.255.252
jakarta(config-if)#clock rate 2000000

Konfigurasi IP Address Router Semarang

semarang(config)#interface FastEthernet0/0
semarang(config-if)#ip address 192.168.0.1 255.255.255.252
semarang(config-if)#no shutdown

semarang(config)#interface Serial0/0
semarang(config-if)#ip address 10.10.10.1 255.255.255.252

Konfigurasi IP Address Router Surabaya

surabaya(config)#interface Loopback0
surabaya(config-if)#ip address 40.40.40.1 255.255.255.252

surabaya(config)#interface FastEthernet0/0
surabaya(config-if)#ip address 192.168.0.2 255.255.255.252
surabaya(config-if)#no shutdown

 

Kemudian setting routing EIGRP dalam postingan ini, saya contohkan konfigurasi routing eigrp dalam 1 AS.

Konfigurasi Routing Router Jakarta

jakarta(config)#router eigrp 10
jakarta(config-if)#network 10.10.10.0 0.0.0.3
jakarta(config-if)#network 30.30.30.0 0.0.0.3
jakarta(config-if)#no auto-summary

Konfigurasi Routing Router Semarang

semarang(config)#router eigrp 10
semarang(config-if)#network 10.10.10.0 0.0.0.3
semarang(config-if)#network 192.168.0.0 0.0.0.3
semarang(config-if)#no auto-summary

Koonfigurasi Routing Router Surabaya

surabaya(config)#router eigrp 10
surabaya(config-if)#network 192.168.0.0 0.0.0.3
surabaya(config-if)#network 40.40.40.0 0.0.0.3
surabaya(config-if)#no auto-summary

Kemudian setelah melakukan konfigurasi Routing EIGRP pada router, periksa masing-masing router status dari protocol routingnya. pada gambar berikut adalah hasil yang benar dan successful ditandai dengan Code D.

Cara-Konfigurasi-EIGRP

Cara-Konfigurasi-EIGRP

cara-konfigurasi-eigrp

Langkah terakhir, Cek apakah network pada masing-masing router sudah dapat terkoneksi atau belum ke network tujuan, lakukan pengecekkan dengan menggunakan perintah PING.

cara-konfig-eigrp-pingstatus

cara-konfig-eigrp-pingstatus

cara-konfig-eigrp-pingstatus

Sebagai acuan anda telah berhasil melakukan konfig EIGRP selain diatas, yaitu dengan melihat notifikasi Adjacency. berikut contoh notifikasi Adjacency yang muncul ketika routing Eigrp telah dimasukkan.

Router Jakarta

%DUAL-5-NBRCHANGE: IP-EIGRP 10: Neighbor 10.10.10.1 (Serial0/0/0) is up: new adjacency

Router Semarang

%DUAL-5-NBRCHANGE: IP-EIGRP 10: Neighbor 192.168.0.2 (FastEthernet0/0) is up: new adjacency

%DUAL-5-NBRCHANGE: IP-EIGRP 10: Neighbor 10.10.10.2 (Serial0/0) is up: new adjacency

Router Surabaya

%DUAL-5-NBRCHANGE: IP-EIGRP 10: Neighbor 192.168.0.1 (FastEthernet0/0) is up: new adjacency

 

Metric Calculation

Untuk menghitung metric pada Eigrp memiliki 5 parameter yaitu Bandwidth, Delay, Reliability, Loading & MTU.

Kemudian masing-masing dari parameter tersebut mempunyai Nilai K (K-Values), K-Value digunakan untuk kalkulasi metric modifier, yang utama dikalkulasikan adalah bandwidth dan delay. :

K-Values :

K1 = Bandwidth Modifier
K2 = Load Modifier
K3 = Delay Modifier
K4 = Reliability Modifier
K5 = Additional Reliability Modifier

Secara Default, nilai dari K1 & K3 adalah 1, kemudian K2 & K4 & K5 nilainya 0.

Jadi Untuk mengukur Metric wajib mempersiapkan 2 parameter yaitu Bandwidth dan Delay pada semua router yang terkoneksi. 2 Parameter yang digunakan dari interface out.

Metric Formula

untuk menghitung metric terdapat rumusnya, yakni :

EIGRP Metric = 256*((K1*Bandwidth) + (K2*Bandwidth)/(256-Load) + K3*Delay)*(K5/(Reliability + K4)))

Ribet yak ? kepanjangan rumusnya, karena parameter Bandwidth dan Delay saja yang memiliki nilai 1, maka ambil saja parameter Bandwidth dan Delay-nya saja. Maka jika di ringkas menjadi :

EIGRP Metric = 256 × ( Bandwidth Value + Delay Value )

NOTE Tambahan :

Jika Ingin menghitung masing masing Nilai Bandwidth dan Delay, ada rumusnya, berikut rumusnya :

Bandwidth Value = 10ˆ7 / Bandwidth_Out_Interface

Sedangkan Nilai Delay, berikut rumusnya :

Delai Value = (( N1 + N2 + N3 + …. Nn) / 10)

Sebagai referensi, nilai yang lebih umum digunakan adalah dalam tabel di bawah ini, serta nilai yang dikonversi untuk Mbps, bps, dan usec.

EIGRP-Bandwidth&Delay Value

Oke, mari kita cari tahu besar metric dari router jakarta ke IP 40.40.40.1 pada router Surabaya.

Pertama, Untuk mengukur Metricnya, wajib mempersiapkan 2 Parameter yang udah gw sebutkan diatas, yaitu Bandwidth dan Delay di semua Interface out router.,

Router Jakarta

Jakarta-ShowInterface-RouterEIGRP

Router Semarang

Semarang-ShowInterface-RouterEIGRP

Router Surabaya

Surabaya-ShowInterface-RouterEIGRP

Oke, dapat dilihat yang saya tandai warna merah pada masing-masing router, karena di Router Jakarta ke Semarang menggunakan Link Serial, maka bandwidth yang digunakan sebesar 1544.

EIGRP Metric  = 256*[(10^7/Bw_Interface_Out)+(Cumulative_Delay/10)]
                              = 256*[(10000000/1544)+(20000+100+5000/10)]
                              = 256*[ 6476,683937823834 + (25100/10) ]
                              = 256*[ 6476,683937823834 + 2510 ]
                              = 256*8986,683937823834
                              = 2300591

Mari Hasilnya 2300591, coba kita check nilai yang dihasilkan oleh Router, dengan menggunakan syntax Show IP Route Destination_IP atau Show IP Route Saja :

Jakarta-ShowIPRoute-EIGRP

Menggunakan Syntax Show IP Route saja :

Jakarta-ShowIPRoute2-EIGRP

Ya,ga beda jauh lah ya, 2300591 dengan 2300416. mungkin teman-teman ada yang tau perhitungan lebih jelasnya, komen dibawah yah 🙂

IP Summarization

Next

 

 

Demikian cara Konfigurasi Routing EIGRP pada Cisco

One Comment

Leave a Comment

Your email address will not be published. Required fields are marked *