CARA KONFIGURASI DYNAMIC ROUTING OSPF DASAR PADA ROUTER CISCO

Setelah kita pelajari Cara Konfigurasi Dynamic Routing : EIGRP pada Router Cisco pada postingan sebelumnya, Pada postingan kali saya akan membahas Cara konfigurasi Dynamic Routing : OSPF pada Router Cisco.

 

Definisi OSPF

OSPF singkatan dari Open Short Path First, merupakan salah satu protocol yang mengunakan metode Link State Routing Protocol, OSPF sendiri termasuk tipe dari Interior Gateway Protocol (IGP). OSPF memperbaiki databasenya dengan informasi topologi yang dikirimkan melalui Trigger Update. Trigger Update ini hanya dikirimkan jika terjadi perunbahan saja. Dengan Protocol OSPF, Router tahu secara detail topologi dari network sehingga memperkecil kesalahan dalam keputusan melakukan routing. Namun berbeda dengan Protocol lain yang tersedia saat ini, OSPF mengunakan Algoritma Link State atau umumnya dikenal dengan Algoritma Djikstra untuk menentukan rute/path terbaiknya.

cara-konfigurasi-ospf

Perbedaan dengan Algoritma Distance Vektor adalah jika Algoritma Distance Vector memiliki informasi yang tidak spesifik tentang distance network dan tidak mengetahui jarak router tetangganya, sedangkan Algoritma Link-state memperbaiki pengetahuannya dari jarak router dan bagaimana mreka inter-koneksi dengan router lainnya. Sehingga OSPF menjadi protocol yang cepat dan scalable. OSPF sendiri idealnya di desain secara hierarchical, agar kita dapat membagi network yang besar ke dalam network-network yang lebih kecilyang disebut dengan Area. Alasan dasar untuk membuat OSPF di desain secara hierarchical itu : Menurunkan Routing Overhead, Mempercepat Convergence, Membatasi Network yang tidak stabil agar tdak menyebar ke area yang lain.

Fitur OSPF

OSPF mempunyai fitur :

  • Autonomous System and Area = OSPF memiliki fitur AS & Area, ini dapat digunakan untuk membagi network-network ke dalam bagian-bagian kecil melalui Area.
  • Minimum Update Traffic = OSPF dapat meminimalkan Routing Update Traffic.
  • Allows Scalability
  • Supported VLSM/CIDR
  • Unlimited Hop Count
  • Open Standard

Router ID

Dalam Routing OSPF dikenal istilah Router ID, Router ID berfungsi sebagai Identitas Router sebagai pengenal antara Router satu dengan yang lain yang tergabung dalam Routing OSPF. Saat OSPF telah Connection established, maka akan tampil notification dari router neighbor (router tetangga), router neighbor yanng ditampilkan ialah berupa Router ID. Berikut Contohnya :

00:58:33: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on Serial0/3/0 from LOADING to FULL, Loading Done

perhatikan contoh diatas, tulisan “Nbr” maksudnya adalah Neighbor, kemudian “Nbr 2.2.2.2” yang ditampilkan pada notification diatas merupakan Router ID.

Dalam proses pemilihan atau penentuan Router ID dalam OSPF ada beberapa cara :

  1. Force router-id, artinya kita bisa memasukkan sendiri IP router-id yang kita inginkan tanpa harus IP Address tersebut ada pada IP Address Interface router.
  2. IP Interface Loopback, artinya jika kalian tidak melakukkan Force router-id, Maka router-id akan ditentukan berdasarkan IP Address tertinggi yang ada pada Interface Loopback aktif router anda.
  3. IP Interface Phisical, artinya jika kalian tidak melakukan Force router-id dan tidak mengaktifkan Interface Loopback, Maka router-id akan ditentukan berdasarkan IP Address tertinggi yang ada pada Interface Phisical aktif router anda.

untuk dapat melihat Router ID pada router kalian, dapat ketik perintah Show IP OSPF :

atau bisa juga melihat Router ID dengan perintah Show IP OSPF Database :

 

Administrative Distance Table

Dalam Terminologi Routing, dikenal istilah Tabel Administrative Distance Number, dimana dalam tabel tersebut berisikan number yang digunakan secara Default oleh perangkat router anda dalam menentukan Protocol Routing mana yang akan digunakan. Perangkat Router akan mengunakan Protocol Routing yang memiliki value/nilai yang terkecil dalam router anda, berikut tabel Administrative Distance.

Tabel Default Value of Administrative Distance

Cara-Setting-Static-Route-pada-Router-Cisco

 

Konfigurasi Basic OSPF

 

cara-konfigurasi-dasar-ospf

Pertama, setting terlebih dahulu ip address pada masing masing interface router. Dan pastikan koneksi antar router telah established.

JAKARTA(config)#interface GigabitEthernet 0/0 
JAKARTA(config-if)#description Link-to-SEMARANG
JAKARTA(config-if)#ip address 10.10.10.2 255.255.255.252 
JAKARTA(config-if)#no shutdown

JAKARTA(config)#interface GigabitEthernet 0/1 
JAKARTA(config-if)#description Link-to-LAN
JAKARTA(config-if)#ip address 5.5.5.5 255.255.255.252 
JAKARTA(config-if)#no shutdown

JAKARTA(config)#interface Loopback 0
JAKARTA(config-if)#ip address 1.1.1.1 255.255.255.255
JAKARTA(config-if)#no shutdown
SEMARANG(config)#interface GigabitEthernet 0/1
SEMARANG(config-if)#description SURABAYA
SEMARANG(config-if)#ip address 192.168.0.1 255.255.255.252
SEMARANG(config-if)#no shutdown

SEMARANG(config)#interface GigabitEthernet 0/0
SEMARANG(config-if)#description Link-To-JAKARTA
SEMARANG(config-if)#ip address 10.10.10.1 255.255.255.252
SEMARANG(config-if)#no shutdown

SEMARANG(config)#interface GigabitEthernet 0/2 
SEMARANG(config-if)#description Link-To-Local 
SEMARANG(config-if)#ip address 6.6.6.4 255.255.255.252 
SEMARANG(config-if)#no shutdown

SEMARANG(config)#interface loopback 0
SEMARANG(config-if)#ip address 2.2.2.2 255.255.255.255
SEMARANG(config-if)#no shutdown
SURABAYA(config)#interface GigabitEthernet 0/0
SURABAYA(config-if)#description Link-To-SEMARANG
SURABAYA(config-if)#ip address 192.168.0.2 255.255.255.252
SURABAYA(config-if)#no shutdown

SURABAYA(config)#interface GigabitEthernet 0/1 
SURABAYA(config-if)#description Link-To-Local 
SURABAYA(config-if)#ip address 7.7.7.7 255.255.255.0 
SURABAYA(config-if)#no shutdown

SURABAYA(config)#interface loopback 0
SURABAYA(config-if)#ip address 3.3.3.3 255.255.255.255
SURABAYA(config-if)#no shutdown

Kemudian setting routing OSPF dalam postingan ini.

Jakarta(config)#router ospf 1
Jakarta(config-router)#network 1.1.1.1 0.0.0.0 area 0
Jakarta(config-router)#network 5.5.5.5 0.0.0.3 area 0
Jakarta(config-router)#network 10.10.10.0 0.0.0.3 area 0
Semarang(config)#router ospf 2 
Semarang(config-router)#network 2.2.2.2 0.0.0.0 area 2 
Semarang(config-router)#network 6.6.6.6 0.0.0.3 area 2 
Semarang(config-router)#network 192.168.0.0 0.0.0.3 area 2 
Semarang(config-router)#network 10.10.10.0 0.0.0.3 area 0 
Surabaya(config)#router ospf 3 
Surabaya(config-router)#network 192.168.0.0 0.0.0.3 area 2 
Surabaya(config-router)#network 3.3.3.3 0.0.0.0 area 2 
Surabaya(config-router)#network 7.7.7.7 0.0.0.255 area 2

 

Pada contoh diatas, masing-masing router OSPF Process ID saya bedakan, anda bisa konfig Process ID masing-masing router itu sama maupun bisa beda.

Langkah kemudian, Cek IP Route pada masing – masing Router, Symbol “O” menandakan Routing OSPF sudah berjalan.

Show IP Route Router JAKARTA

cara-konfig-ospf-showiproute

 

Show IP Route Router SEMARANG

cara-konfig-ospf-showiproute

Show IP Route Router SURABAYA

cara-konfig-ospf-showiproute

Oh iya, jangan lupa tambahkan konfigurasi Router-ID pada masing-masing Router OSPF. sebagai Identitas masing-masing Router.

Jakarta(config)#router ospf 2
Jakarta(config-router)#router-id 5.5.5.5
Jakarta(config-router)#Reload or use "clear ip ospf process" command, for this to take effect
Semarang(config)#router ospf 2
Semarang(config-router)#router-id 6.6.6.6
Semarang(config-router)#Reload or use "clear ip ospf process" command, for this to take effect
Surabaya(config)#router ospf 3
Surabaya(config-router)#router-id 7.7.7.7
Surabaya(config-router)#Reload or use "clear ip ospf process" command, for this to take effect

Setelah melakukan konfigurasi Router-ID, router minta untuk dilakukan clear process Ospf, agar OSPF dapat mengkalkulasi process OSPF.

Jakarta#clear ip ospf process

Reset ALL OSPF processes? [no]: y

 

Semarang#clear ip ospf process

Reset ALL OSPF processes? [no]: y

 

Surabaya#clear ip ospf process

Reset ALL OSPF processes? [no]: y

 

Kemudian dalam OSPF jika dalam konfigurasi berjalan dengan baik, akan tampil notifikasi OSPF Neighbor pada CLI masing-masing Router.

JAKARTA

00:00:40: %OSPF-5-ADJCHG: Process 1, Nbr 6.6.6.6 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

 

SEMARANG

04:18:23: %OSPF-5-ADJCHG: Process 2, Nbr 5.5.5.5 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

04:18:30: %OSPF-5-ADJCHG: Process 2, Nbr 7.7.7.7 on GigabitEthernet0/1 from LOADING to FULL, Loading Done

 

SURABAYA

00:00:40: %OSPF-5-ADJCHG: Process 3, Nbr 6.6.6.6 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

04:18:30: %OSPF-5-ADJCHG: Process 3, Nbr 6.6.6.6 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

 

Langkah terakhir, periksa apakah network pada masing-masing router sudah dapat terkoneksi atau belum, lakukan pengecekkan dengan menggunakan perintah PING.

Check PING Router Jakarta

cara-konfig-OSPF-PING-R0

Check PING Router Semarang

cara-konfig-OSPF-PING-R1

Check PING Router Surabaya

cara-konfig-OSPF-PING-R2

jika kalian lakukan Ping connection berhasil, maka kalian telah berhasil melakukan konfigurasi Basic OSPF. pada Postingan selanjutnya akan saya bahas cara konfigurasi OSPF Lanjutan.

. tunggu ya.

 

Salam.

Leave a Comment

Your email address will not be published. Required fields are marked *